Plugins

As information about new vulnerabilities is discovered and released into the general public domain, Tenable Research designs programs to detect them. These programs are named plugins and are written in the Nessus Attack Scripting Language (NASL). The plugins contain vulnerability information, a simplified set of remediation actions and the algorithm to test for the presence of the security issue. Tenable Research has published 126818 plugins, covering 50001 CVE IDs and 29642 Bugtraq IDs.

Search

IDNameProductFamilySeverity
124198Oracle Java SE 1.7.0_221 / 1.8.0_211 / 1.11.0_3 / 1.12.0_1 Multiple Vulnerabilities (Apr 2019 CPU)NessusWindowshigh
124197Oracle Java SE 1.7.0_221 / 1.8.0_211 / 1.11.0_3 / 1.12.0_1 Multiple Vulnerabilities (Apr 2019 CPU) (Unix)NessusMisc.high
124196Cisco IOS XE Software for Cisco Catalyst Switches IPv4 Denial of Service VulnerabilityNessusCISCOhigh
124195Juniper Junos SRX crafted packets destined to fxp0 denial of service (JSA10927)NessusJunos Local Security Checksmedium
124194Security Update for Microsoft Office (Apr 2019) (macOS)NessusMacOS X Local Security Checkshigh
124193Juniper Junos jdhcpd crash denial of service (JSA10926)NessusJunos Local Security Checksmedium
124192VMSA-2019-0006 : VMware ESXi, Workstation and Fusion updates address multiple out-of-bounds read vulnerabilitiesNessusVMware ESX Local Security Checksmedium
124191Ubuntu 18.10 : znc vulnerability (USN-3950-1)NessusUbuntu Local Security Checksmedium
124190SUSE SLES12 Security Update : php5 (SUSE-SU-2019:0985-1)NessusSuSE Local Security Checkshigh
124189openSUSE Security Update : libqt5-qtbase (openSUSE-2019-1239)NessusSuSE Local Security Checksmedium
IDNameProductFamilySeverity
124121Oracle Business Intelligence Publisher Multiple Vulnerabilities (Apr 2019 CPU)NessusWindowsmedium
124050openSUSE Security Update : the Linux Kernel (openSUSE-2019-1193)NessusSuSE Local Security Checkshigh
124038Debian DSA-4430-1 : wpa - security updateNessusDebian Local Security Checksmedium
124004Atlassian Confluence < 6.6.12 / 6.7.x < 6.12.3 / 6.13.x < 6.13.3 / 6.14.x < 6.14.2 Template InjectionNessusCGI abuseshigh
124001Citrix SD-WAN Center DetectionNessusMisc.info
123999Ubuntu 14.04 LTS / 16.04 LTS / 18.04 LTS / 18.10 : wpa vulnerabilities (USN-3944-1)NessusUbuntu Local Security Checksmedium
123729EulerOS Virtualization 2.5.3 : elfutils (EulerOS-SA-2019-1261)NessusHuawei Local Security Checksmedium
123698EulerOS Virtualization 2.5.3 : ntp (EulerOS-SA-2019-1230)NessusHuawei Local Security Checksmedium
123679Ubuntu 14.04 LTS / 16.04 LTS : linux-hwe, linux-aws-hwe, linux-azure, linux-gcp, linux-oracle (USN-3931-2)NessusUbuntu Local Security Checkshigh
123678Ubuntu 18.04 LTS : linux, linux-aws, linux-gcp, linux-kvm, linux-oem, linux-oracle, (USN-3931-1)NessusUbuntu Local Security Checkshigh