Facebook Google Plus Twitter LinkedIn YouTube RSS Menú Buscar Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

HAProxy 1.6.x < 1.6.4 Multiple Vulnerabilities

High

Synopsis

The remote host is running a version of HAProxy that is affected by multiple attack vectors.

Description

The installed version of HAProxy installed version 1.6.x prior to 1.6.4, and is affected by multiple vulnerabilities :

- An Off-by-one flaw exists in the SSL component that is triggered during ALPN and NPN list allocation. No further details have been provided. (OSVDB 135912) - A flaw in the http-reuse component exists that is triggered as private connections are shared across backends. No further details have been provided by the vendor. (OSVDB 135913) - An Off-by-one issue exists in the 'url_param' parser in the http component. No further details have been provided by the vendor. (OSVDB 135914)

Soluciones

Upgrade to HAProxy version 1.6.4 or higher.