Facebook Google Plus Twitter LinkedIn YouTube RSS Menú Buscar Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

PostgreSQL 9.1.x < 9.1.24 / 9.2.x < 9.2.19 / 9.3.x < 9.3.15 / 9.4.x < 9.4.10 / 9.5.x < 9.5.5 Multiple Vulnerabilities

High

Synopsis

The database running on the remote server is affected by multiple attack vectors.

Description

The version of PostgreSQL installed on the remote host is 9.1.x prior to 9.1.24, 9.2.x prior to 9.2.19, 9.3.x prior to 9.3.15, or 9.4.x prior to 9.4.10, or 9.5.x prior to 9.5.5 and is affected by multiple vulnerabilities :

- A use-after-free error exists that is triggered when executing aggregate functions using 'DISTINCT'. This may allow a remote attacker to dereference already freed memory and cause a crash. (OSVDB 146590) - A flaw exists due to the Interactive installer downloading software insecurely over an HTTP connection. This may allow a man-in-the-middle attacker to potentially execute arbitrary code. (OSVDB 157419)

Soluciones

Upgrade to PostgreSQL 9.5.5 or later. If 9.5.x cannot be obtained, 9.4.10, 9.3.15, 9.2.19, and 9.1.24 have also been patched for this vulnerability.