Facebook Google Plus Twitter LinkedIn YouTube RSS Menú Buscar Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Advantech WebAccess < 8.2_20161101 Multiple Vulnerabilities

Critical

Synopsis

The detected version of Advantech WebAccess may be affected by multiple attack vectors.

Description

The installed version of Advantech WebAccess is prior to 8.2_20161101 and is affected by the following vulnerabilities :

- An unspecified flaw exists in the authentication mechanism. This may allow a remote attacker to bypass authentication and access restricted pages. (CVE-2017-5152) - A flaw exists that may allow carrying out an SQL injection attack. The issue is due to the 'updateTemplate.aspx' script not properly sanitizing input to unspecified parameters. This may allow an authenticated, remote attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data. (CVE-2017-5154) - A flaw exists that is triggered when loading certain dynamic-link libraries. The program uses an insecure path to look for specific files or libraries that includes the current working directory, which may not be trusted or under user control. By placing a specially crafted library in the path, a local attacker can inject and execute arbitrary code with the privilege of the user running the program. (CVE-2017-5175)

Soluciones

Upgrade to Advantech WebAccess version 8.2_20161101 or later.