Facebook Google Plus Twitter LinkedIn YouTube RSS Menú Buscar Resource - BlogResource - WebinarResource - ReportResource - Eventicons_066 icons_067icons_068icons_069icons_070

Atlassian Confluence Server 5.10.x < 5.10.6 XSS

Medium

Synopsis

The remote Confluence server is affected by a cross-site scripting (XSS) vulnerability.

Description

Versions of Confluence 5.10.x prior to 5.10.6 contain a flaw that allows a stored XSS attack. This flaw exists because the '/pages/doeditattachment.action' script does not validate input attachment filenames after their initial submission, e.g. via the 'newFileName' parameter. This may allow an authenticated remote attacker to edit an attachment's filename after it has been submitted to potentially execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.

Soluciones

Upgrade to Confluence 5.10.x version 5.10.6 or later.